Installation failing on OSX

Steven Zou <sz...@...>



  So far, the OSX is not officially verified and supported.




Steven (邹佳)


Engineer, CNA, VMware R&D


Mail: sz...@...

Cell: +8618600021252

Addr: 9F Tower C, Raycom Info Tech Park, No. 2 Kexueyuan South Road Haidian District, Beijing 100738 China




From: <harb...@...> on behalf of Vishnu Vardhan <va...@...>
Date: Thursday, December 27, 2018 at 06:02
To: harbor-users <harb...@...>
Subject: Installation failing on OSX




A basic installation on OSX is failing.


All components are installing, and I get the following message in the end - 




✔ ----Harbor has been installed and started successfully.----


Now you should be able to visit the admin portal at 

For more details, please visit .



But connection to that host fails with connection refused:


~/Downloads/harbor $ curl

curl: (7) Failed to connect to port 8888: Connection refused



I first tried the default port - but that was not working, and so tried to change the port - following instructions on GitHub. Same error



I had some permissions trouble during the install and had to 

1. Create directories manually (e.g /data/redis)

2. Change ownership of some directories from root to my user name

    e.g /var/log/harbor, ./common/config/custom-ca-bundle.crt



The only change to the harbor.cfg is the hostname ( with our without the custom port.


Please advice.








You received this message because you are subscribed to the Google Groups "harbor-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to harbor-users+unsu...@....
To post to this group, send email to harbor...@....
To view this discussion on the web visit
For more options, visit