Date   

RC2 of Strimzi Kafka Operators 0.29.0 is available for testing

Jakub Scholz
 

Release candidate 2 of Strimzi Kafka Operators 0.29.0 is now available for testing. The changes since RC1 are:
* Fix Kafka, KafkaConnect and Cruise Control examples
* Fix error handling in KafkaRebalance processing
* Fix bugs in Rack-awareness and upgrade system tests

Any feedback can be provided on the Strimzi mailing list, on the #strimzi Slack channel on CNCF Slack or as a GitHub issue.

Thanks & Regards
Strimzi team


RC1 of Strimzi Kafka Operators 0.29.0 is available for testing

Jakub Scholz
 

Release candidate 1 of Strimzi Kafka Operators 0.29.0 is now available for testing. The changes in this release include for example:
* Support for new Apache Kafka releases (3.0.1, 3.1.1 and 3.2.0)
* Renew user certificates in User Operator only during maintenance windows
* New rebalancing modes in the `KafkaRebalance` custom resource to add or remove brokers
* Experimental KRaft mode (ZooKeeper-less Kafka)
* Experimental support for the s390x platform


Any feedback can be provided on the Strimzi mailing list, on the #strimzi Slack channel on CNCF Slack or as a GitHub issue.

Thanks & Regards
Strimzi team


[ANNOUNCE] [RELEASE] Strimzi Kafka Bridge 0.21.5

Jakub Scholz
 

New version 0.21.5 of Strimzi Kafka Bridge has been released. The main changes in this release are:
* Support for ppc64le platform
* Documentation improvements
* Dependency updates


Thanks to everyone who contributed to to this releases!

Regards
Strimzi team


RC1 of Strimzi Kafka Bridge 0.21.5

Jakub Scholz
 

Release Candidate 1 of Strimzi Kafka Bridge the 0.21.5 is now available for testing. The main changes since 0.21.4 are:
* Support for ppc64le platform
* Documentation improvements
* Dependency updates

More details and a full list of changes can be found on the GitHub release page: https://github.com/strimzi/strimzi-kafka-bridge/releases/tag/0.21.5-rc1

Any feedback can be provided on the mailing list, on Slack or as a GitHub issue.

Thanks & Regards
Strimzi team


Re: Flink-kafka consume errors.

Jakub Scholz
 

If your Flink is running inside the same Minikube, I guess you should use the "type: internal" listener for it. Your Minikube seems to map the load balancer to 127.0.0.1 - so I have some doubts it if works the same way from inside and outside your Minikube because in each case, 127.0.0.1 will refer to something else.

Jakub

On Sun, Apr 10, 2022 at 8:22 PM <raghunittala@...> wrote:

I have installed strimzi kafka on minikube and also flink operator (provided by spotify) on minikube (both are installed on different namespaces). I have done minikube tunnelling and with that, I am able to issue command line kafka commands with localhost:9094 as the bootstrap server address/broker list. I'm able to create the topics, consume from and publlish to with 127.0.0.1:9094. I wrote a sample kafka producer in java that publishes several messages to kafka topic and that is also working fine with "localhost:9094"

When I try to consume from flink, with broker list as "127.0.0.1:9094", I end up in below exception:

I'm not able to understand, why with flink I'm not able to consume where in kafka. Here are the pods that are enabled in the kafka namespace:

Can someone help me on this?


Flink-kafka consume errors.

raghunittala@...
 

I have installed strimzi kafka on minikube and also flink operator (provided by spotify) on minikube (both are installed on different namespaces). I have done minikube tunnelling and with that, I am able to issue command line kafka commands with localhost:9094 as the bootstrap server address/broker list. I'm able to create the topics, consume from and publlish to with 127.0.0.1:9094. I wrote a sample kafka producer in java that publishes several messages to kafka topic and that is also working fine with "localhost:9094"

When I try to consume from flink, with broker list as "127.0.0.1:9094", I end up in below exception:

I'm not able to understand, why with flink I'm not able to consume where in kafka. Here are the pods that are enabled in the kafka namespace:

Can someone help me on this?


[ANNOUNCE] [RELEASE] Strimzi Kafka Operators 0.28.0

Jakub Scholz
 

Strimzi Kafka Operators 0.28.0 has been released. The main changes in this release include:
* Add support for Kafka 3.1.0; remove Kafka 2.8.0 and 2.8.1
* Add support for `StrimziPodSet` resources (disabled by default through the `UseStrimziPodSets` feature gate)
* Support custom authentication mechanisms in Kafka listeners
* Intra-broker disk balancing using Cruise Control
* Added the option `createBootstrapService` in the Kafka Spec to disable the creation of the bootstrap service for the Load Balancer Type Listener. It will save the cost of one load balancer resource, specially in the public cloud.
* Add support for disabling the FIPS mode in OpenJDK
* Fix renewing your own CA certificates

For more details and installation files, go to https://github.com/strimzi/strimzi-kafka-operator/releases/tag/0.28.0

We have also created a video about the changes in this release which you can watch on our YouTube channel: https://youtu.be/PZKbrDUU1zo

Important: This release supports only the API version v1beta2 and CRD version apiextensions.k8s.io/v1. If upgrading from Strimzi 0.22, migration to v1beta2 needs to be completed for all Strimzi CRDs and CRs before the upgrade to 0.28 is done! If upgrading from Strimzi version earlier than 0.22, you need to first install the CRDs from Strimzi 0.22 and complete the migration to v1beta2 for all Strimzi CRDs and CRs before the upgrade to 0.28 is done! For more details about the CRD upgrades, see the documentation.

Thanks to everyone who contributed to these releases!

Thanks & Regards
Strimzi team


RC1 of Strimzi Kafka Operators 0.28.0 is available for testing

Jakub Scholz
 

Release candidate 1 of Strimzi Kafka Operators 0.28.0 is now available for testing. The main changes in this release include:
* Add support for Kafka 3.1.0; remove Kafka 2.8.0 and 2.8.1
* Add support for `StrimziPodSet` resources (disabled by default through the `UseStrimziPodSets` feature gate)
* Support custom authentication mechanisms in Kafka listeners
* Intra-broker disk balancing using Cruise Control
* Added the option `createBootstrapService` in the Kafka Spec to disable the creation of the bootstrap service for the Load Balancer Type Listener. It will save the cost of one load balancer resource, specially in the public cloud.
* Add support for disabling the FIPS mode in OpenJDK
* Fix renewing your own CA certificates


Any feedback can be provided on the Strimzi mailing list, on the #strimzi Slack channel on CNCF Slack or as a GitHub issue.

Thanks & Regards
Strimzi team


[ANNOUNCE] [RELEASE] Strimzi Kafka Bridge 0.21.4

Jakub Scholz
 

New version 0.21.4 of Strimzi Kafka Bridge has been released. The main changes in this release are:
* Dependency updates (Configuration providers, Vert.x, Netty, Oauth client and more)
* Add support for disabling the FIPS mode in OpenJDK
* Add transactions `isolation.level` configuration parameter on consumer creation
* Support for s390x platform


Thanks to everyone who contributed to any of these releases!

Regards
Strimzi team


[ANNOUNCE] [RELEASE] Mirror Maker 2 Extensions 1.2.0, EnvVar Configuration Provider 1.0.0 and Kubernetes Configuration Provider 1.0.0

Jakub Scholz
 

New versions of Mirror Maker 2 Extensions, EnvVar Configuration Provider and Kubernetes Configuration Provider have been released.

The biggest change involves the Mirror Maker 2 Extensions. The Strimzi Identity Replication Policy is now deprecated and all users of Kafka 3.0.0 and higher are recommended to update their configurations and use the Identity Replication Policy which is directly part of the Apache Kafka project. The 1.2.0 release of the Mirror Maker 2 Extensions is used for backwards compatibility and provides the same behaviour as the Kafka policy but using the original Strimzi class name. The Config Provider releases contain minor improvements and dependency updates. For more details, visit the release pages of each project:

* Mirror Maker 2 Extensions: https://github.com/strimzi/mirror-maker-2-extensions/releases/tag/1.2.0
* Kafka EnvVar Configuration Providerhttps://github.com/strimzi/kafka-env-var-config-provider/releases/tag/1.0.0
* Kafka Kubernetes Configuration Providerhttps://github.com/strimzi/kafka-kubernetes-config-provider/releases/tag/1.0.0

Thanks to everyone who contributed to any of these releases!

Regards
Strimzi team


RC1 of Mirror Maker 2 Extensions 1.2.0, EnvVar Configuration Provider 1.0.0 and Kubernetes Configuration Provider 0.1.1

Jakub Scholz
 

As we are preparing for the next release of the Strimzi operators, we are doing different minor and patch releases of some of our smaller projects used as dependencies. Today, we released the Release Candidate 1 of several sub-projects:
* Mirror Maker 2 Extensions: https://github.com/strimzi/mirror-maker-2-extensions/releases/tag/1.2.0-rc1
* Kafka EnvVar Configuration Provider: https://github.com/strimzi/kafka-env-var-config-provider/releases/tag/1.0.0-rc1
* Kafka Kubernetes Configuration Provider: https://github.com/strimzi/kafka-kubernetes-config-provider/releases/tag/1.0.0-rc1

They contain some smaller bug fixes and improvements as well as updated dependencies. If you are interested, give them a try! Any feedback can be provided on the Strimzi mailing list, on the #strimzi Slack channel on CNCF Slack or as a GitHub issue.

Thanks & Regards
Strimzi team


[ANNOUNCE] [RELEASE] Strimzi Kafka Operators 0.27.1

Jakub Scholz
 

Strimzi Kafka Operators 0.27.1 has been released. The main changes in this release include:
* Fix Helm Chart issue when configuring additional environment variables
* Update Log4j2 to 2.17.1
* Update Fabric8 Kubernetes Client to 5.10.2

For more details and installation files, go to https://github.com/strimzi/strimzi-kafka-operator/releases/tag/0.27.1

Important: This release supports only the API version v1beta2 and CRD version apiextensions.k8s.io/v1. If upgrading from Strimzi 0.22, migration to v1beta2 needs to be completed for all Strimzi CRDs and CRs before the upgrade to 0.27 is done! If upgrading from Strimzi version earlier than 0.22, you need to first install the CRDs from Strimzi 0.22 and complete the migration to v1beta2 for all Strimzi CRDs and CRs before the upgrade to 0.27 is done! For more details about the CRD upgrades, see the documentation.

Thanks to everyone who contributed to this release!

Thanks & Regards
Strimzi team


[ANNOUNCE] [RELEASE] Strimzi Kafka Operators 0.27.0 and Strimzi Drain Cleaner 0.3.0

Jakub Scholz
 

Strimzi Kafka Operators 0.27.0 has been released. The main changes in this release include:
* (Experimental) support for AArch64 / ARM64 platform
* The ControlPlaneListener and ServiceAccountPatching feature gates are now in the beta phase and are enabled by default.
* Updated Log4j2 dependency to 2.17.0

For more details and installation files, go to https://github.com/strimzi/strimzi-kafka-operator/releases/tag/0.27.0

We have also created a video about the changes in this release which you can watch on our YouTube channel: https://youtu.be/cdAz997VC_0

Important: This release supports only the API version v1beta2 and CRD version apiextensions.k8s.io/v1. If upgrading from Strimzi 0.22, migration to v1beta2 needs to be completed for all Strimzi CRDs and CRs before the upgrade to 0.27 is done! If upgrading from Strimzi version earlier than 0.22, you need to first install the CRDs from Strimzi 0.22 and complete the migration to v1beta2 for all Strimzi CRDs and CRs before the upgrade to 0.27 is done! For more details about the CRD upgrades, see the documentation.

----

We also released Strimzi Drain Cleaner 0.3.0. The main changes in this release include support for both v1beta1 and v1 versions of the Eviction API and updates of dependencies.

For more details and installation files, go to https://github.com/strimzi/drain-cleaner/releases/tag/0.3.0

----

Thanks to everyone who contributed to these releases!

Thanks & Regards
Strimzi team


RC2 of Strimzi Kafka Operators 0.27.0

Jakub Scholz
 

Release candidate 2 of Strimzi Kafka Operators 0.27.0 is now available for testing. The changes since RC1 are:
* Fixed AArch64 version of the kaniko-executor container image
* Add Canary installation files to release archives


Any feedback can be provided on the Strimzi mailing list, on the #strimzi Slack channel on CNCF Slack or as a GitHub issue.

Thanks & Regards
Strimzi team


RC1 of Strimzi Kafka Operators 0.27.0 and Strimzi Drain Cleaner 0.3.0 available for testing

Jakub Scholz
 

Release candidate 1 of Strimzi Kafka Operators 0.27.0 is now available for testing. The main changes in this release include:
* (Experimental) support for AArch64 / ARM64 platform
* The ControlPlaneListener and ServiceAccountPatching feature gates are now in the beta phase and are enabled by default.
* Updated Log4j2 dependency to 2.17.0


----

Also available is Release Candidate 1 of the Strimzi Drain Cleaner 0.3.0. The main changes in this release include support for both v1beta1 and v1 versions of the Eviction API and updates of dependencies.

For more details and installation files, go to https://github.com/strimzi/drain-cleaner/releases/tag/0.3.0-rc1

Any feedback can be provided on the Strimzi mailing list, on the #strimzi Slack channel on CNCF Slack or as a GitHub issue.

Thanks & Regards
Strimzi team


[ANNOUNCE] [RELEASE] Strimzi Operators 0.26.1

Jakub Scholz
 

Strimzi Operators release 0.26.1 is now available. The main change in this release is the fix for the Log4j2 CVE-2021-44228. For more details, go to https://github.com/strimzi/strimzi-kafka-operator/releases/tag/0.26.1

The updates to OperatorHub.io and OpenShift OperatorHub are still work in progress. The Java artifacts might need some additional time to propagate.

If you for some reason cannot upgrade to Strimzi 0.26.1, you can check the possible mitigations on GitHub Discussions.

Thanks to everyone who contributed to this release!

Thanks & Regards
Strimzi team


[ANNOUNCE] [RELEASE] Strimzi Kafka Bridge 0.21.0

Jakub Scholz
 

Strimzi Kafka Bridge 0.21.0 is now available. It will be also used in the upcoming  0.27.0 and 0.26.1 releases of Strimzi Operators. The main changes in this release are support for Arm64 / AArch64 architecture and the fix for the Log4j2 CVE-2021-44228. For more details, go to https://github.com/strimzi/strimzi-kafka-bridge/releases/tag/0.21.0

If you use an older version of the Strimzi Cluster Operator which uses Strimzi Kafka Bridge 0.20.x, you should be able to run the 0.21.0 version without any problems. Just edit the Cluster Operator deployment and set the STRIMZI_DEFAULT_KAFKA_BRIDGE_IMAGE environment variable to quay.io/strimzi/kafka-bridge:0.21.0.

Thanks to everyone who contributed to this release!

Thanks & Regards
Strimzi team


RC2 of Strimzi Kafka Bridge 0.21.0

Jakub Scholz
 

Release Candidate 2 of Strimzi Kafka Bridge the 0.21.0 is now available for testing. The only change since RC1 is the update of the Log4j dependency which fixes CVE-2021-4428.  More details and a full list of changes can be found on the GitHub release page: https://github.com/strimzi/strimzi-kafka-bridge/releases/tag/0.21.0-rc2

Any feedback can be provided on the mailing list, on Slack or as a GitHub issue.

Thanks & Regards
Strimzi team


RC1 of Strimzi Kafka Bridge 0.21.0

Jakub Scholz
 

Release Candidate 1 of Strimzi Kafka Bridge the 0.21.0 is now available for testing. The main changes since 0.20.x are experimental support for AArch64 / ARM64 architectures. More details and a full list of changes can be found on the GitHub release page: https://github.com/strimzi/strimzi-kafka-bridge/releases/tag/0.21.0-rc1

Any feedback can be provided on the mailing list, on Slack or as a GitHub issue.

Thanks & Regards
Strimzi team


[ANNOUNCE] [RELEASE] Strimzi Drain Cleaner 0.2.0 released

Jakub Scholz
 

We have released Strimzi Drain Cleaner 0.2.0. Strimzi Drain Cleaner is a utility which helps with moving the Kafka pods deployed by Strimzi from Kubernetes nodes which are being drained. The version 0.2.0 delivers several minor bugfixes and improvements. For more details about what Drain Cleaner does and how to use it, check the README.md file.

For more details and installation files, go to: https://github.com/strimzi/drain-cleaner/releases/tag/0.2.0

Thanks to everyone who contributed to this release!

Thanks & Regards
Strimzi team

1 - 20 of 123