RC1 of Strimzi Operators 0.25.0


Jakub Scholz
 

Release Candidate 1 of Strimzi Operators 0.25.0 is now available for testing with a lot of changes and improvements. 

Important: This release supports only the API version v1beta2 and CRD version apiextensions.k8s.io/v1. If upgrading from Strimzi 0.22, migration to v1beta2 needs to be completed for all Strimzi CRDs and CRs before the upgrade to 0.25 is done! If upgrading from Strimzi version earlier than 0.22, you need to first install the CRDs from Strimzi 0.22 and complete the migration to v1beta2 for all Strimzi CRDs and CRs before the upgrade to 0.25 is done! For more details about the CRD upgrades, see the documentation.

The main changes since the 0.24 release include:
* Move from Scala 2.12 to Scala 2.13
* Open Policy Agent authorizer updated to a new version supporting Scala 2.13
* Allow a custom password to be set for SCRAM-SHA-512 users by referencing a secret in the KafkaUser resource
* Add support for EnvVar Configuration Provider for Apache Kafka
* Add support for tls-external authentication to User Operator to allow management of ACLs and Quotas for TLS users with user certificates generated externally
* Support for disabling the automatic generation of network policies by the Cluster Operator
* Update User Operator to use Admin API for managing SCRAM-SHA-512 users
* Configure fixed size limit for emptyDir volumes used for temporary files
* Update Strimzi Kafka Bridge to 0.20.2

There are also several deprecations and removals. For more details and installation files, go to https://github.com/strimzi/strimzi-kafka-operator/releases/tag/0.25.0-rc1

Any feedback can be provided on the Strimzi mailing list, on the #strimzi Slack channel on CNCF Slack or as a GitHub issue.

Thanks & Regards
Strimzi team

Join cncf-strimzi-dev@lists.cncf.io to automatically receive all group messages.