RC1 of Strimzi Operators 0.24.0


Jakub Scholz
 

Release Candidate 1 of Strimzi Operators 0.24.0 is now available for testing with a lot of changes and improvements. 

Important: This release supports only the API version v1beta2 and CRD version apiextensions.k8s.io/v1. If upgrading from Strimzi 0.22, migration to v1beta2 needs to be completed for all Strimzi CRDs and CRs before the upgrade to 0.24 is done! If upgrading from Strimzi version earlier than 0.22, you need to first install the CRDs from Strimzi 0.22 and complete the migration to v1beta2 for all Strimzi CRDs and CRs before the upgrade to 0.24 is done! For more details about the CRD upgrades, see the documentation.

The main changes since the 0.23 release include:
* Add support for Kubernetes Configuration Provider for Apache Kafka
* Use Red Hat UBI8 base image
* Add support for Kafka 2.7.1 and remove support for 2.6.0, 2.6.1, and 2.6.2
* Support for patching of service accounts and configuring their labels and annotations.
* Added support for configuring cluster-operator's worker thread pool size
* Add Kafka Quotas plugin with produce, consume, and storage quotas
* Support pausing reconciliation of KafkaTopic CRs
* Update cruise control to 2.5.55
* Update to Strimzi Kafka Bridge to 0.20.0
* Selectively changing the verbosity of logging for individual CRs
* Added support for `controller_mutation_rate` quota
* Use newer version of Kafka Exporter with different bugfixes 

There are also several deprecations and removals. For more details and installation files, go to https://github.com/strimzi/strimzi-kafka-operator/releases/tag/0.24.0-rc1

Any feedback can be provided on the Strimzi mailing list, on the #strimzi Slack channel on CNCF Slack or as a GitHub issue.

Thanks & Regards
Strimzi team

Join cncf-strimzi-dev@lists.cncf.io to automatically receive all group messages.