about exam again

Agoton DEIM


I posted this previously but everything was replaced with a link - maybe because of the pictures. If you click on the links you can find the pictures and the original text. I've just seen that because the digest is my preference over individual emails.
Besides that I read that "For each question you'll see the point value at the bottom and we're relocated some items so that fewer high value questions are at the end. However, since we're trying to minimize the amount of manual
navigation across the different clusters, you'll still find that the second 'half' has a higher point value than the first 'half'." But as far as I remember I didn't see points. But that' s not so important to me but maybe I was on an older version of the exam?

br, Agoston


today I tried to take an exam but I gave up eventually.

First the exam was very slow and the terminal was unusable. It was laggy and slow. After every command I had to wait 10-15 secs to get the prompt back. And that was not because I deployed hundreds of pods it was the same for kubectl get pods and kubectl get pv etc.
I issued the command "w" to see the load and it was 44.23.... I checked the number of cores before I complained to the proctor. The VM or bare metal had 16 core (/proc/cpuinfo is very helpful). I told him about my problem. He asked me to be patient and tried to get help.
Than the connection was lost. When it was restored I checked the load numerous times and it was still between 22-35. Ok, it was a bit more responsive, still slow.
I had connectivity problems as well. The connection was lost several times and when I noted that and that the terminal is slow the proctor told me that's because my connection is slow.... Yeah, the load level as high as 44 because of the speed of my connection? LOL. Besides that it's a 120Mbit connection and I know that towards various datacenters it's not same but I checked it after the exam (you see my tests below).
Once the connection lost and restored I found a clear, grey terminal without any prompt..... I asked the proctor for help and they reseted something - the connection lost and restored. After that I tried to schedule a deployment but I got an error that the etcd service is unavailable.....
So, I found out the hard way that this exam is still very-very beta in terms of the exam environment. I gave up at this time because the previous exam was very slow and it was in "ungradable state" whatever it means - I think the environment and the screen and camera record was lost or damaged. I didn't want to sit 5 hours in front of the computer to waste another 5 hours from my life - 4 hours for the exam, 1 hour for the various related stuff like checking my identity and waiting to repair the exam env.

I also checked my internet connection towards the exam environment. I found out from the firewall logs that I had lots of connections towards amazon aws when I started the exam. And I know that the screen and camera stream goes towards there because I had to disable some protection in the firewall (invalid ssl packets towards the exam environment) when I took the previous exam. To make a long story short I checked my connection towards Amazon AWS with the help of and everything was fine. I connected to eu-west-1 datacenter I attach the edited screenshot - I just cut the interesting part out to make the picture smaller but I can send you the whole image - and you can see the detailed connection test as well on separate pictures. So, I don't think the speed of my connection caused any problems.
So the problems didn't went away. Previously the exam was just a bit slow to me but I was able to do the test - I didn't check the load back then - it just turned out that the whole sank into a blackhole... or such a thing.

I know it's a beta exam and the environment is complex and demanding lots of horsepower but when can we expect a stable environment to take and exam without any glitches? Should we just wait a bit and don't try again soon - that's my intention - and do you have a schedule?

br, Agoston