Topics

PSA: Timelines For Removing Kuberntes Deprecated APIs - extensions/v1beta1, apps/v1beta1, apps/v1beta2


Matt Farina
 

Kubernetes has an API deprecation policy. The extensions/v1beta1, apps/v1beta1, and apps/v1beta2 APIs are long past their deprecation window. They are now being deprecated.

In Kubernetes 1.16 (the next minor release) the following API objects will no longer be accepted by the API server:

  • DaemonSet, Deployment, StatefulSet, and ReplicaSet from the extensions/v1beta1, apps/v1beta1, or apps/v1beta2 API groups. Please migrate to apps/v1 which works all the way back to Kubernetes 1.9
  • PodSecurityPolicy from the extensions/v1beta1 API Group. Please migrate to policy/v1beta1 which has been available since Kubernetes 1.10
  • NetworkPolicy from extensions/v1beta1 API group. Please migrate to networking.k8s.io/v1 which has been available since Kubernetes 1.8.

In Kubernetes 1.18 Ingress from the extensions/v1beta1 API group will no longer be accepted. As of Kubernetes 1.14 it is available under the networking.k8s.io/v1beta1 API group. Migrating this API will be more difficult as public cloud providers are only just not beginning to support Kubernetes 1.14. It may be useful to detect either Kubernetes or the objects existence in the chart and generate the proper resource.

If there are any questions please feel free to ask.

- Matt Farina